Working with Foresight Analytics Platform in some cases may cause various problems. Below are the most common cases and causes of their occurrence and solutions:
Emergency shutdown of application with activated performance tests
Problem
Emergency shutdown of BI server process with activated performance tests.
Cause
Emergency shutdown occurs due to triggering of data execution prevention (DEP). When measuring memory consumption, memory allocation or deallocation function calls are intercepted. This is done by recording executable code bytes to memory that triggers the prevention.
Solution
Memory is measured only if data execution prevention is disabled. The prevention can be disabled as follows:
Select the System > Advanced System Settings item on the control panel.
Click the Settings button on the Advanced tab in the Performance area.
Select the Turn On DEP for Essential Windows Programs and Services Only radio button on the Data Execution Prevention tab or add appropriate exceptions:
When IIS are used, add the w3wp.exe file located in the C:\Windows\System32\inetsrv\ directory to exceptions.
When Apache web server is used, add the httpd.exe file from the directory with installed Apache web server to exceptions.
Connection was closed by administrator
Problem
When working with Foresight Analytics Platform the following message is displayed:
The connection was closed by administrator.
Contact the administrator.
Cause
This problem may occur if the user was disconnected from the repository by the administrator.
Solution
Contact the administrator to know when you can continue working with the repository. To continue, reconnect to the repository.
Problem
When working in Foresight Analytics Platform in the web application or in the designer of business applications the following error occurs:
Cause
Server connection may be lost if there is no internet connection and/or BI server is unavailable.
Solution
To solve the problem:
Do not close the browser tab if data was not saved.
Connect to the Internet and/or ensure access to BI server. To check BI server performance, see the Checking BI Server Performance section.
Click the Check Connection button.
After executing the operations the message is displayed indicating the server connection restore status:
If server connection is restored, continue working with Foresight Analytics Platform.
If the the session is timed out while there was no server connection, try to authorize again and continue working with Foresight Analytics Platform.
If server connection failed to restore, contact the administrator.
Problem
Working with Foresight Analytics Platform in the web application or in the designer of business applications the following error occurs:
Cause
Session is timed out.
Solution
To solve the problem, authorize again in the login dialog box using the Log in button. After successful authorization, the current page opens where the error occurred.
For details about setting up work timeouts see the Setting Up Work Timeouts dialog box.
Access denied on working with repository
Problem
When repository connection settings are created, edited, or deleted, that is used for all users, the user is denied access.
NOTE. The repository is used for all users if the Anyone Who Uses This Computer radio button is selected in the Repository Parameters checkbox has been selected for it.
Cause
The problem may occur if:
Foresight Analytics Platform is running without elevating privileges when UAC is enabled.
The user does not have permissions to write into the HKEY_LOCAL_MACHINE registry key.
Solution
Log in to Foresight Analytics Platform as an administrator.
Repository settings cannot be saved
Problem
When the user who is not included into the local administrators group creates repository connection settings, used for the current user, new repository settings are not saved after Foresight Analytics Platform restart.
Cause
When the Only for Me radio button is selected, appropriate registry record is executed. The list of added repositories will be empty because registry values cannot be read.
NOTE. The repository is used for the current user if the Only for Me radio button is selected in the Repository Parameters checkbox selected.
Solution
To solve the problem, grant the user registry reading permissions.
Running Microsoft Office applications do not show the Foresight tab
Problem
After Foresight add-ins have been installed, the Foresight tab is not shown on the ribbon on starting Microsoft Office applications.
Solution
Make sure that bitness of the installed desktop application of Foresight Analytics Platform, Microsoft Office applications in use, and the installed Foresight Add-In match. To ensure correct work, bitness of all three components should match. If bitness mismatch, resolve the problem by installing components with matching bitness. Restart Microsoft Office for changes to take effect.
Make sure that versions of the installed desktop application of Foresight Analytics Platform and the installed Foresight Add-In match. To ensure correct work, versions should match. If versions mismatch, resolve the problem by installing components with matching versions. Restart Microsoft Office for changes to take effect.
If the Foresight tab has not appeared, go to document options and on the Add-Ins tab select the Foresight Add-In in the list of inactive add-ins. In the Manage drop-down list select the COM Add-Ins option and click the Go button. Then select the checkbox next to the add-in and click the OK button. Restart Microsoft Office for changes to take effect.
Add add-in location to Trusted Locations. To do this, open document parameters and on the Trust Center tab click the Trust Center Settings button. In the Trust Center dialog box that opens go to the tab:
Trusted Locations. Add a new location to the User Locations list and specify path to the installed Foresight Analytics Platform, for example: C:\Program Files\Foresight\Analytics Platform 10.x\.
Add-ins. Make sure that checkboxes for add-in constraints are deselected on the tab.
Restart Microsoft Office for changes to take effect.
Make sure that the LoadBehavior parameter is set to 3 in the registry keys:
[HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\Foresight.ExcelAddIn] - subsection for current user settings.
[HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Excel\Addins\Foresight.ExcelAddIn] - subsection for all users settings.
The operating system in English on login to repository displays question marks instead of names in Russian
Problem
On working in the operating system in English after connecting to repository, object names set in Russian are displayed as question marks.
Cause
A repository has been created in an operating system in Russian, and the For Unicode Charset section.
Solution
This problem can be solved only by recreating a repository and selecting the For Unicode Charset checkbox. The databases that contain repository settings must also have the Use Unicode Encoding for Data Representation section.
DBMS repository connection throws the error "ERROR: ORA-21561: OID generation failed"
Problem
After Foresight Analytics Platform BI server has been installed in a RedHat-based distribution file, on connecting to Oracle DBMS based repository the error occurs
ERROR: ORA-21561: OID generation failed.
Cause
The error is not related to Foresight Analytics Platform, this may be due to the hosts file contents.
Solution
To resolve the error, perform the following operations:
Find computer's IP address ("ip a" command) and computer network name ("hostname" command).
sudo nano /etc/hosts
On creating a repository on PostgreSQL server an error message is displayed
Problem
After finishing preparation of PostgreSQL server, when repository is created, the repository manager shows the error message.
Cause
Most frequently errors on working with PostgreSQL driver occur when the path to the Bin folder of the PostgreSQL driver is not added to the Path variable in Windows environment variables.
Solution
It is required to set up PostgreSQL server strictly according to help materials:
PostgreSQL server is prepared by the DBMS administrator. The preparation includes the steps described in the Preparing PostgreSQL Server section.
After all steps in the item 1 have been successfully executed, create a repository.
Error converting MDM dictionary or composite MDM dictionary into table MDM dictionary
Problem
An error occurs on converting MDM dictionary or composite MDM dictionary into table MDM dictionary. Possible error text:
OLE\COM 0x80040E14. Microsoft SQL Server Native Client 10.0 MSSQL-102: Incorrect syntax near '@errno'.
Cause
If metadata schema was earlier transferred from Microsoft SQL Server 2008 to Microsoft SQL Server 2012, MDM dictionaries are not converted. Transferring of schemas between different DBMS versions is not supported due to difference in SQL syntax.
Solution
Update MDM repository by means of repository manager (RepoMngr.exe). After the successful update repeat dictionary conversion.
Errors on working in calculation block formula editor
Problem
On working in calculation block formula editor of the Calculation Algorithms extension the Access Violation… or Error Loading Form/Component errors occur.
Cause
The problem is not related with Foresight Analytics Platform, it is Windows system defect.
Solution
To solve the problem:
The Foresight Analytics Platform bitness must be the same as Windows bitness.
Install the last Windows OS updates.
Error accessing files on updating cube cache
Problem
When cube cache is updated in the repository navigator or from application code, an error accessing cache files occurs. The error may also occur on executing cache update task in task scheduler.
Cause
Cache files are used by another instance of Foresight Analytics Platform. For example, BI server instance and desktop application of Foresight Analytics Platform.
Solution
Cube cache should be updated only if one platform instance is running. The task scheduler should be started on a separate server that does not use desktop application or BI server of Foresight Analytics Platform. One can also set up cache update task execution on a separate BI server.
Error opening database in web application
Problem
In web application, on opening objects linked to database, the following error appears:
Database opening rejected.
Cause
On working with objects linked to database, the database opens. To open the database, user credentials are required.
On database creation, the automatic connection was not set up and on objects opening, the Database Authorization dialog box must be opened to input user name and password, but it is not supported in web application.
Solution
To solve the problem, in web application set up automatic connection to database:
Open the database in use for edit.
Go to the Database Properties in the database edit wizard.
Select the Automatic Connection checkbox and select one of the connection options:
Select the Use Login Credentials checkbox.
Determine user credentials that will be used for server connection.
Click the Next button. The connection to database will be checked.
Click the Ready button on the last page to close the wizard.
Error on creating an automatic cube
Problem
An error occurs on creating an automatic cube in the desktop application:
The selected database does not contain tables and procedures required for MDM repository.
Cause
Tales and procedures required for MDM metadata repository are missing or corrupted.
Solution
To solve the problem, in the desktop application:
See also:
Solving Possible Problems in Foresight Analytics Platform