On startup and login to Foresight Analytics Platform in some cases the following errors may occur.
Problem
On Foresight Analytics Platform startup the platform integrity violation is detected, the following error message is displayed instead of the login dialog box:
Files integrity is violated: <file name>.
Cause
This problem may occur if executable files or libraries are missing or do not correspond with the standard.
Solution
In this case contact the administrator.
On Foresight Analytics Platform startup error message does not appear but the application shuts down
Problem
On Foresight Analytics Platform startup error message does not appear but Foresight Analytics Platform shuts down.
If the user clicks the Cancel button in the login dialog box, error message does not appear, and Foresight Analytics Platform shuts down.
Cause
Possible causes:
On working with the 64-bit operating system the DeviceLock software solution of the version earlier than 7.1 is used.
Framework installation errors occurred.
Solution
Below are the variants of solving the problem. If the variant does not work, go to the next variant.
Check correspondence of the DeviceLock version with the system type, install DeviceLock software solution of the later version, for example, 7.1 or later.
Reinstall Microsoft .NET Framework, having previously removed Microsoft .NET Framework Client 4 Profile and Microsoft .NET Framework 4 Extended.
Application initialization error
Problem
On Foresight Analytics Platform startup one of the messages is displayed:
Foresight Analytics Platform settings require automatic update of versions.
Version cannot be updated as the <'C:\Program Files\Foresight\Foresight Analytics Platform 10.x\Studio.exe'> execution completed with error. Error code -1073741515.
Studio.exe - Could not find component.
Application could not start because mfc110u.dll was not found. Reinstall the application to solve this problem.
Studio.exe - Application error.
Application initialization error (0xc0000135). To exit the application, click the OK button.
Cause
This problem may occur if the workstation does not contain necessary prerequisites.
Solution
Start the installer again and on the Program Maintenance page select the Repair option.
File api-ms-win-crt-runtime-l1-1-0.dll not found
Problem
On Foresight Analytics Platform startup the message is displayed:
The program cannot start, because the file api-ms-win-crt-runtime-l1-1-0.dll is missing. Try re-installing the program.
Cause
This problem may occur if the workstation has removed or has incorrectly installed the Microsoft Visual C++ 2019 Redistributable Package prerequisite.
Solution
Start the Microsoft Visual C++ 2019 Redistributable Package installer, installer bitness must match that of Foresight Analytics Platform. The installer is located in the ISSetupPrerequisites folder in the same folder with the installer of Foresight Analytics Platform.
Installation of the Microsoft Visual C++ 2019 Redistributable Package on Windows Server 2012 R2 requires updates KB2975061 and KB2919355.
Repository version is earlier/later than version of Foresight Analytics Platform
Problem
On authorization in Foresight Analytics Platform the following message is displayed in the login dialog box:
Repository version is earlier/later than Foresight Analytics Platform.
Cause
This problem may occur if the repository version mismatches the platform version.
Solution
In this case contact the administrator.
Problem
On Foresight Analytics Platform startup, the following error message is displayed:
Error connecting to the database. The <Oracle 12.x\18.x> client is not found.
Cause
Possible causes:
Oracle DBMS front end is not installed.
Bitness of Foresight Analytics Platform and Oracle DBMS front end mismatch.
Solution
Check if Oracle DBMS front end is installed, and if its bitness matches with that of Foresight Analytics Platform.
Error connecting to PostgreSQL DBMS based repository
Problem
Connecting to the repository may return the error:
Error loading PostgreSQL functions library. Perhaps the driver is not installed.
Cause
Installed PostgreSQL driver is missing or driver bitness differs from that of Foresight Analytics Platform. The error may also occur if there is no Microsoft Visual C++ Runtime Library package on the user computer even if a DBMS driver is correctly installed.
Solution
Check if the installed driver exists and its bitness. If the required driver is installed, download and install the vcredist file of the appropriate bitness from the website www.microsoft.com.
It is also recommended to add the path to the folder with installed PostgreSQL DBMS drivers to the PATH variable.
"Connection to database failed. Oracle 12.x/18.x is not found" error
Problem
On connecting to Oracle DBMS based repository via BI server the error may occur:
Connection to database failed. Oracle 12.x/18.x is not found.
Cause
The ISS web server interacts with the Oracle client under the Network Service and IUSR users instead of the user who addresses the web server. The user may be denied to access the Oracle client if the Network Service and IUSR users do not have appropriate access permissions.
Solution
To solve the problem, allow the Network Service and IUSR users to access the folder with the Oracle client.
"Process cannot access the file because it is being used by another process" error
Problem
Connecting to the repository may return the error:
The process cannot access the file because it is being used by another process.
Cause
Linux OS uses Tmpfs.
Solution
To solve the problem, cancel the use of Tmpfs to store temporary files on the hard drive. The Tmpfs file system does not support attributes required for correct work of Foresight Analytics Platform repository.
"Invalid user name/Password and user name box is empty/Password is not set" errors
Problem
On authorization in Foresight Analytics Platform the following error message is displayed in the login dialog box:
Invalid user name/password.
The User Name box is empty/The password is not set.
Cause
On authorization, user name or password were not specified or were specified incorrectly.
Solution
Reenter user name and password in the login dialog box.
Problem
On authorization in Foresight Analytics Platform the following message is displayed in the login dialog box:
Security policy prescribes password change.
If the new password is not set or the Cancel button is clicked, the following error message is displayed:
User must change password.
Cause
This problem may occur if the maximum password age set in the policy editor is expired.
Solution
Password change is required. To do this, enter the password in the window with the notification about password change requirement and click the Yes button.
If a new password does not satisfy password policy requirements, the appropriate information appears below the edit boxes. Select password in accordance with the rules. After the password is changed, the web application session is finished. To log in to the system, open a new browser window.
Problem
On authorization in Foresight Analytics Platform the following message is displayed:
The '<user name>' user is locked.
Cause
Possible causes:
Password errors limit is overrun.
User is locked by the administrator.
Solution
In this case contact the administrator.
Problem
On authorization in Foresight Analytics Platform one of the following messages is displayed in the login dialog box:
Login is denied for the '<user name>' user.
System access from the '<workstation address>' for the current user is denied.
Login is denied for the '<user name>' user.
System access from the workstation with IP address '<workstation IP address>' for the '<user name>' user is denied.
Login is denied for the '<user name>' user.
System access from the workstation with MAC address '<workstation MAC address>' for the '<user name>' user is denied.
Login is denied for the '<user name>' user.
Login for the '<user name>' user is currently denied. Deny period ends HH:MM:SS.
Cause
User access is denied:
From this workstation.
From the station with defined IP address.
From the station with defined MAC address.
On this day.
In this period.
Solution
In this case contact the administrator.
The user has insufficient permissions to access object navigator
Problem
On authorization in Foresight Analytics Platform the following message is displayed in the login dialog box:
The <user name> user has insufficient permissions to access object navigator.
Cause
This problem may occur if the user does not have the Login to Object Navigator privilege.
Solution
In this case contact the administrator.
The "Access Denied" error message on authorization in the web application
Problem
Authorization in the web application returns the message:
Access denied.
Contact the administrator.
Registration in the desktop application is executed without errors.
Cause
This problem may occur if parameters of the SQLNET.ORA configuration file are incorrectly specified. The file is located at S\network\admin\, where S is the Oracle installation path.
Solution
For the correct password authentication in the SQLNET.ORA configuration file replace SQLNET.AUTHENTICATION_SERVICES = (NTS) with SQLNET.AUTHENTICATION_SERVICES = (NONE).
Services not found on authorization in the web application
Problem
After installation of the web application on the authorization attempt the system returns the error that services are not found (ServiceNotFound).
Cause
The address for web services is specified in basic settings of the web application in the PP.xml file. Services address is case-sensitive that is why if the case is incorrect, the error occurs.
Solution
The path of the files depends on the type of the web server in use:
ASP.NET: S\Config.
Java: S\pp\WEB-INF.
where S is the path to the folder with installed web application.
When the PP.xml file is opened for edit, check the correctness of the web services address considering the case in the "service url="S1" />" string. Where S1 is the path to BI server.
Default paths on using IIS server:
http://<BI server>/fpBI_App_v10.x/axis2/services/PP.SOM.Som
Where <BI server> is the name or IP address of the server where the BI server works.
After changes are saved, open the web application and repeat authorization.
Invalid repository identifier on authorization in the web application
Problem
After installation of the web application on the authorization attempt the system returns the error that the repository identifier is invalid.
Solution
Close the browser window and start the Foresight Analytics Platform desktop application with Administrator permissions on the server and web services installed.
Click the Settings button in the dialog box. In the list of available repositories select the one, which is used on an attempt of authorization in the web application, and click the Edit button.
In the dialog box that opens select the Anyone Who Uses This Computer checkbox to make the repository available for all users and enable the web services to interact with Foresight Analytics Platform.
After saving changes restart the web server with the web services, open the web application and repeat the authorization procedure.
Error creating/updating user on working in repository based on PostgreSQL DBMS
Problem
On creating or updating user, the "Error while granting access permissions on DBMS objects. Try to update users" error occurs.
Solution
If the Public default schema is used on working with PostgreSQL DBMS, all repository users will be able to create tables. This behavior is related to the features of PostgreSQL DBMS work. It may lead to problems of user update and taking into account access permissions of users that are repository administrators. To avoid the error, it is recommended to create all objects only under the users included into the Administrators group.
See also:
Solving Possible Problems in Foresight Analytics Platform