The following are the most common license validation problems, reasons of their occurrence and solution methods:
License is missing or has expired
Problem
On startup, Foresight Analytics Platform displays one of the following messages:
License file is not found.
Trial license expired.
Cause
Possible causes:
License file is missing.
License is expired.
License server is not available.
Solution
Contact technical support by sending a request to support@fsight.ru or using technical support services, which are available after registration at the website.
Problem
A message about license limitation is displayed on the application work:
To perform this action, activate the Dashboards/Data Warehouse Designer license, and so on.
Cause
The executed action requires to have an additional feature.
Solution
It is required to activate the feature that enables the user to perform the required action.
To get additional features, contact technical support by sending a request to support@fsight.ru or using technical support services, which are available after registration at the website.
To update a license in the desktop application:
Merge the license in use with the received feature. Open the current license file in a text editor and the received feature, copy their contents into one file, save and name it lservrc without extension.
TIP. The license in use can be found at: %PROGRAMDATA%\Foresight\Foresight Analytics Platform\
Apply the merged license file in one of the ways:
Replace the license file at: %PROGRAMDATA%\Foresight\Foresight Analytics Platform\
Open the activation wizard using the Windows main menu: Foresight Analytics Platform 9.2 > License Manager. In the dialog box that opens select in the License list the Foresight Analytics Platform feature, click the Activate button next to it. Select the merged license file in the activation wizard that opens. Click the Activate button to finish activation process.
To work in the web application, activate Foresight Analytics Platform on BI Server. To do this, contact the BI server administrator.
License file contains incorrect activation code
Problem
On startup, Foresight Analytics Platform displays a message about incorrect activation code:
License file contains incorrect activation code.
Cause
Possible causes:
If a temporary license is used, the time set on a workstation does not fall into the interval determined in the license.
A network license is selected instead of a stand-alone license or vice versa.
The fingerprint of the computer, on which the application is activated, does not match the fingerprint set in the license.
License contains activation code of previous versions of the platform.
Solution
In all cases it is required to replace license file. To get a new license, contact technical support by sending a request to support@fsight.ru or using technical support services, which are available after registration at the website.
See also:
Solving Possible Problems in Foresight Analytics Platform