При работе с «Форсайт. Аналитическая платформа» в отдельных случаях могут возникать различные проблемы. Ниже описаны наиболее распространенные из них, а также причины их появления и пути решения:

Аварийное
завершение приложения при активированных замерах производительности
Проблема
Процесс BI-сервера аварийно завершается при активированных замерах производительности.
Причина
Аварийное завершение происходит по причине срабатывания защиты от выполнения данных (DEP). При замерах потребления памяти осуществляется перехват вызова функций выделения/освобождения памяти. Для этого выполняется запись байтов исполняемого кода в память, что приводит к срабатыванию защиты.
Решение
Замеры памяти будут работать только при выключенной защите от выполнения данных. Выключение осуществляется следующим образом:
в панели управления выберите «Система/Дополнительные параметры системы»;
на вкладке «Дополнительно» в разделе «Быстродействие» нажмите кнопку «Параметры»;
на вкладке «Предотвращение выполнения данных» выберите флаг «Включить DEP только основных программ и служб Windows» или добавьте соответствующие исключения:
при использовании IIS: добавьте в исключения файл «w3wp.exe», расположенный в каталоге «c:\Windows\System32\inetsrv\»;
при использовании веб-сервера Apache: добавьте в исключения файл «httpd.exe» из каталога, куда установлен веб-сервер Apache.

Соединение
разорвано администратором
Проблема
При работе с «Форсайт. Аналитическая платформа» появляется следующее сообщение:
Соединение разорвано
администратором.
Обратитесь к администратору.
Причина
Эта проблема может возникнуть, если пользователь был отключен от репозитория администратором.
Решение
Необходимо уточнить у администратора время, по истечении которого можно продолжить работу с репозиторием. Для продолжения необходимо будет переподключиться к репозиторию.

Отказ
в доступе при работе с репозиторием
Проблема
При создании, редактировании или удалении настроек подключения к репозиторию, предназначенному для всех пользователей, пользователю было отказано в доступе.
Примечание. Репозиторий предназначен для всех пользователей, если установлен переключатель «Для всех пользователей на компьютере» в диалоге «Параметры репозитория».
Причина
Проблема может возникнуть, если:
продукт «Форсайт. Аналитическая платформа» запущен без повышения привилегий при включенном UAC;
у пользователя отсутствуют права на запись в реестр в ветку HKEY_LOCAL_MACHINE.
Решение
Выполните вход в «Форсайт. Аналитическая платформа» с правами администратора.

Не
сохраняются настройки репозитория
Проблема
При создании пользователем, не входящим в группу локальных администраторов, настроек подключения к репозиторию, предназначенного для текущего пользователя, после перезапуска «Форсайт. Аналитическая платформа» настройки нового репозитория не будут сохранены.
Причина
При установке переключателя в положение «Для текущего пользователя» происходит запись в реестр. Список добавленных репозиториев будет пустой, так как нет возможности прочитать значения реестра.
Примечание. Репозиторий предназначен для текущего пользователя, если установлен переключатель «Для текущего пользователя» в диалоге «Параметры репозитория».
Решение
Для решения проблемы необходимо дать пользователю права на чтение реестра.

При
запуске приложений Microsoft Office не появляется вкладка «Foresight»
Проблема
После установки надстроек Foresight Add-In при запуске приложений Microsoft Office на ленте инструментов не появляется вкладка «Foresight».
Решение
Проверьте, совпадают ли разрядности «Форсайт. Аналитическая платформа»,
Microsoft Office и надстройки Foresight
Add-In.
Проверьте, совпадают ли версии «Форсайт. Аналитическая платформа»
и надстройки Foresight
Add-In.
Если разрядности и версии не совпадают, приведите их в соответствие
друг другу.
Если вкладка «Foresight» не появилась,
перейдите в параметры документа и на вкладке «Надстройка»
в списке неактивных надстроек выберите «Foresight
Add-In».
В раскрывающемся списке «Управление»
выберите «Надстройки COM»
и нажмите кнопку «Перейти».
Затем установите флажок напротив надстройки и нажмите кнопку «OK».
Чтобы изменения вступили в силу, перезапустите приложение Microsoft
Office.

На
английской операционной системе при входе в репозиторий вместо русских
наименований отображаются знаки вопроса
Проблема
Во время работы в английской операционной системе после подключения к репозиторию наименования объектов, которые были заданы на русском языке, отображаются в виде знаков вопроса «?».
Причина
Репозиторий был создан из-под русской операционной системы и для него не был выставлен флажок «Для работы с набором символов Юникод».
Решение
Данную проблему можно решить только путем пересоздания репозитория с установленным флажком «Для работы с набором символов Юникод». Также для баз данных, которые содержат настройки репозитория, необходимо установить флажок «Использовать кодировку юникод для представления данных».

При
подключении к СУБД репозитория возникает ошибка «ERROR: ORA-21561: OID
generation failed»
Проблема
После установки BI-сервера «Форсайт. Аналитическая платформа» в RedHat-подобном дистрибутиве при подключении к репозиторию на базе СУБД Oracle возникает ошибка
ERROR: ORA-21561: OID generation failed.
Причина
Ошибка не связана с «Форсайт. Аналитическая платформа», причиной может быть содержимое файла hosts.
Решение
Для исправления ошибки выполните следующие действия:
Посмотрите IP-адрес компьютера (команда: ip a) и сетевое имя компьютера (команда: hostname).
sudo nano /etc/hosts

При
создании репозитория на сервере PostgreSQL появляется сообщение об ошибке
Проблема
После прохождения процедуры подготовки сервера PostgreSQL, при создании репозитория в менеджере репозитория появляется сообщение об ошибке.
Причина
Наиболее распространенные ошибки в работе с драйвером PostgreSQL связаны с тем, что в переменных среды Windows не добавлен путь до папки «Bin» драйвера PostgreSQL в переменную «Path».
Решение
Необходимо подготовить сервер PostgreSQL строго в соответствии со справочными материалами:
Процедура подготовки сервера PostgreSQL производится администратором СУБД и состоит из шагов, описанных в разделе «Подготовка сервера PostgreSQL».
После успешного выполнения всех шагов из п.1 следует перейти к созданию репозитория.

Ошибка
при конвертации справочника НСИ или составного справочника НСИ в табличный
справочник НСИ
Проблема
Возникает ошибка при конвертации справочника НСИ или составного справочника НСИ в табличный справочник НСИ. Возможный текст ошибки:
OLE\COM 0x80040E14. Microsoft SQL Server Native Client 10.0 MSSQL-102: Incorrect syntax near '@errno'.
Причина
Если ранее схема метаданных была перенесена с Microsoft SQL Server версии 2008 на Microsoft SQL Server версии 2012, то справочники НСИ не будут преобразованы. Перенос схем между различными версиями СУБД не поддерживается из-за разницы в синтаксисе SQL.
Решение
Обновите репозиторий НСИ с помощью менеджера репозитория (RepoMngr.exe). После успешного обновления повторите конвертацию справочников.

Возникает
ошибка «Catastrophic failure»
Проблема
При работе с веб-приложения из-под пользователя, который не является локальным администратором или отсутствует в списке пользователей на компьютер, где установлен BI-сервер, возникает ошибка:
Catastrophic failure.
Причина
Ошибка возникает при использовании операции ForeExec во время выполнения какого-либо Fore.NET-метода. Связана с ошибкой .NET Framework, который обращается к ветке реестра системной учетной записи «NetworkService» - [HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings] и не получает к ней доступ. Из-под этой учетной записи запускается пул приложения BI-сервера.
Решение
Для решения проблемы необходимо дать доступ на чтение указанной ветки реестра пользователю, под которым осуществляется работа.

Возникают
ошибки при работе в редакторе формул блока расчёта
Проблема
При работе в редакторе формул блока расчёта расширения «Алгоритмы расчёта» возникают ошибки вида: «Access violation…» и «Ошибка при загрузке формы/компонента…».
Причина
Проблема не связана с «Форсайт. Аналитическая платформа», это системный дефект ОС Windows.
Решение
Для решения проблемы:
разрядность продукта «Форсайт. Аналитическая платформа» должна совпадать с разрядностью ОС Windows;
установите последние обновления ОС Windows.
См. также:
Решение возможных проблем с продуктом «Форсайт. Аналитическая платформа»