Installation and update in some cases may cause various problems. Below are the most common cases and causes of their occurrence, and solutions.

Cannot open database file. "System Error - 2147287035"
Problem
Installation of Prognoz Platform 9 returns the following error message:
Error "Database: <path to the *.ipi file>. Cannot Open Database File. System error -2147287035"/"Database: <path to the *.ipi file>. Cannot open database file. System error -2147287035".
Cause
Possible causes:
User variables have been changed in the TEMP and TMP environments.
Incorrect permissions have been set for the folder with one of the installed files.
Solution
Below are the variants of solving the problem. If the variant does not work, go to the next variant.
If a user variable has been changed and differs from the default value, return the value of these variables: %USERPROFILE%\AppData\Local\Temp.
Create a new user, add it to the administrators group and start the installation.
Disable antivirus software during the installation.

Installation rollback on connection via remote desktop
Problem
When installing via remote desktop, the installation has been rolled back. The problem occurs on installation of the Full, Standard, and BIServer kits.
NOTE. This problem may be accompanied with opening of the Windows Installer Coordinator and Windows Installer dialog boxes. The Windows Installer dialog box will contain the message "Install server not responding".
Cause
This problem may occur if the installation folder contains an MSI file of help system setup package (PP9Help_RU.msi or PP9Help_EN.msi).
Solution
For correct remote installation of Prognoz Platform 9 install separately Prognoz Platform 9 and help system. To separately install Prognoz Platform 9, the folder with Prognoz Platform 9 installer must not contain help system MSI installer. After Prognoz Platform 9 has been installed, start the help system MSI installer (PP9Help_RU.msi or PP9Help_EN.msi).

BIServer kit installation rollback
Problem
On installing the BIServer kit installation rollback occurred. The error occurs if installation is executed by means of the PP9BIServer[Apache/IIS]_x86.exe or PP9BIServer[Apache/IIS]_x64.exe installers.
Cause
This problem may occur if not all necessary IIS components were installed by the user during IIS setup.
Solution
Install all necessary IIS components. See IIS setup description in the Installing Prognoz Platform 9 Web Application. Step 6. Setting Up Internet Information Services document or on the help system page.

Could not find files to install required components
Problem
Installation of Prognoz Platform 9 returns the following error message:
Could not find files to install required Microsoft SQL Server Native Client 2008 R2 x64 components. Installation will be stopped. It may be connected with unsuccessful or aborted loading.
Cause
This problem may occur if the installer could not find the Microsoft SQL Server Native Client 2008 R2 prerequisite that must be located in the ISSetupPrerequisites folder.
Solution
When installing, the folder with the installer must contain the ISSetupPrerequisites folder with all necessary software that is required for Prognoz Platform 9 work. See the list of prerequisites in the Prognoz Platform 9 help systemPrognoz Platform 9 help system.
Problem
Installation of Prognoz Platform 9 returns the following error message:
Error 1402: "Cannot open key: <key>. Check if there are sufficient access permissions for this key or contact the system engineer.
Cause
This problem may occur if the setup program cannot open the registry section because of the absence of permissions for it.
Solution
Below are the variants of solving the problem. If the variant does not work, go to the next variant.
Open registry editor (regedit.exe). Expand the branch HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components (name S-1-5-18 may differ). Find GUID with the numbers and letters set from the error message. Open the context menu of this GUID section and select the Permissions item. Use the Add button in the Group Permissions dialog box to add the "Administrator", "Administrators", and "system" accounts. If the current administrator account name differs from the Administrator, enter the current user name. Go back to the Group Permissions dialog box. Select each added account and make sure that the Full Access and the Read checkboxes are selected. Click the More button and in the Additional Security Parameters window dialog box execute the following operations:
Select the Replace All Child Object Permissions with Inheritable Permissions from This Object checkbox on the Permissions tab (the Include Inheritable Permissions from This Object's Parent checkbox must be selected).
Select the Administrators name on the Owner tab and select the Replace Subcontainer and Object Owner checkbox.
Use the SubInACL Microsoft utility (http://www.microsoft.com/en-us/download/details.aspx?id=23510) and execute the set of commands in the following sequence:
path_to_file/subinacl.exe /subkeyreg HKEY_LOCAL_MACHINE /setowner=Administrator.
path_to_file/subinacl.exe /subkeyreg HKEY_CURRENT_USER /setowner=Administrator.
path_to_file/subinacl.exe /subkeyreg HKEY_CLASSES_ROOT /setowner=Administrator.
path_to_file/subinacl.exe /subkeyreg HKEY_LOCAL_MACHINE /grant=Administrator=f /grant=system=f.
path_to_file/subinacl.exe /subkeyreg HKEY_CURRENT_USER /grant=Administrator=f /grant=system=f.
Path_to_the_file/subinacl.exe /subkeyreg HKEY_CLASSES_ROOT /grant=Administrator=f /grant=system=f.

Missing operating system update permissions
Problem
Prognoz Platform 9 installation returned the Failed prerequisite installation status. On an attempt to manually install the prerequisite the following error message appears:
Missing permissions to update <OS_name>. Contact the system administrator. / You do not have permission to update <OS name>. Please contact your system administrator.
Cause
This problem may occur if on installing the prerequisites there are not enough permissions for group policy objects.
For details see http://support.microsoft.com/kb/888791.
Solution
Check permissions to group policy objects:
File and catalog archiving.
File and catalog recovery.
Auditing and security log management.
File and other object owner assignment.
System shutdown.
Program debugging.
To view and change user permissions, execute the operations listed below:
Start the group policy objects editor for the local computer or domain. Additional information is described in the Group Policy Management Console article on the Microsoft corporation site.
In the Computer Configuration section select the Windows Configuration element.
Select the Security Settings item, and then Local Policies and User Rights Assignment items.
Set up access permissions to all objects, necessary to install.

The process that started Prognoz Platform installation does not wait installation finish
Problem
When starting the Prognoz Platform 9 installer the process is initialized that copies and starts the installer from a temporary folder. After copying has been made, the process finishes its work before the installation is finished. If several installers are started one by one, all of them are started at the same time. This may result in installation conflict.
Cause
The problem is related to InstallShield 2016 installation features, based on which all Prognoz Platform 9 installers are created.
Solution
To solve the problems, in installer startup options add the parameter clone_wait:
PP9Full.exe /clone_wait
If several installers are started one by one:
PP9Full.exe /clone_wait
"Prognoz Add-in for Excel.exe" /clone_wait

Transformations application error
Problem
Updating of the current version of Prognoz Platform 9 or deleting of Prognoz Platform 9 returns the error message:
Transformations application error. Verify that the specified transform paths are valid"/"Error applying transforms. Verify that the specified transform paths are valid.
Cause
The problem is not related with Prognoz Platform 9, this is a floating error of Windows Installer used for installation.
Solution
To resolve the problem:
Run registry editor.
In the registry branch HKEY_CLASSES_ROOT\Installer\Products\ find the section related to Prognoz Platform 9. The search can be executed using the keyword: "Prognoz Platform".
In the found section delete the Transforms parameter.
To avoid occurring the problem in the future it is recommended to execute the following operations:
Find the registry branch HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer (if the Installer section is missing, create it).
In the Installer section create the DWORD TransformsSecure parameter with the 0 value.
Deselect the Cache Transforms in Secure Location on Workstation checkbox in the local group policy editor for the Windows Installer application:
Using the Start/Run menu, start the gpedit.msc application.
Go to the section Local Computer Policy\Computer Configuration\Administrative Templates\Windows Features\Windows Installer.
Find the specified option and set the Disabled mode. On executing this operation, the TransformsSecure flag with the 0 value is created in the registry.
If remote access is executed via the operating system earlier than Windows Server 2008, create the EnableAdminTSRemote DWORD parameter with the 1 value in the branch HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer.
See also:
Solving Possible Problems on Installing, Starting, and Working in Prognoz Platform 9