Working of Prognoz Platform 9 in certain cases may cause various problems. Below are the most common cases and causes of their occurrence and solutions:

Emergency shutdown of application with activated performance tests
Problem
Emergency shutdown of BI server process with activated performance tests.
Cause
Emergency shutdown occurs due to triggering of data execution prevention (DEP). When measuring memory consumption, memory allocation or deallocation function calls are intercepted. This is done by recording executable code bytes to memory that triggers the prevention.
Solution
Memory is measured only if data execution prevention is disabled. The prevention can be disabled as follows:
Select the System > Advanced System Settings item in the control panel.
Click the Settings button on the Advanced tab in the Performance area.
Select the Turn On DEP for Essential Windows Programs and Services Only radio button on the Data Execution Prevention tab or add appropriate exceptions:
When IIS are used, add the w3wp.exe file located in the C:\Windows\System32\inetsrv\ directory to exceptions.
When Apache web server is used, add the httpd.exe file from the directory with installed Apache web server to exceptions.

Connection was closed by administrator
Problem
Working with Prognoz Platform 9 returns the following message:
The connection was closed by administrator.
Contact administrator.
Cause
This problem may occur if the user was disconnected from the repository by the administrator.
Solution
Learn from your administrator, when you can continue working with the repository. To continue, re-connect to the repository.

Access denied on working with repository
Problem
When repository connection settings are created, edited, or deleted, that is used for all users, the user is denied access.
NOTE. The repository is used for all users if the Anyone Who Uses This Computer radio button is selected in the Repository Parameters dialog box.
Cause
The problem may occur if:
Prognoz Platform 9 is running without elevating privileges when UAC is enabled.
The user does not have permissions to write into the HKEY_LOCAL_MACHINE registry branch.
Solution
Log in to Prognoz Platform 9 as an administrator.

Repository settings cannot be saved
Problem
When the user who is not included into the local administrators group creates repository connection settings, used for the current user, new repository settings are not saved after Prognoz Platform 9 restart.
Cause
When the Only for Me radio button is selected, appropriate registry record is executed. The list of added repositories will be empty because registry values cannot be read.
NOTE. The repository is used for the current user if the Only for Me radio button is selected in the Repository Parameters dialog box.
Solution
To solve the problem, grant the user registry reading permissions.

Running Microsoft Office applications do not show the PROGNOZ tab
Problem
After Prognoz Add-In add-ins have been installed, the PROGNOZ tab is not shown on the ribbon on starting Microsoft Office applications.
Solution
Check if bitness of Prognoz Platform, Microsoft Office and Prognoz Add-In match.
Check if Prognoz Platform and Prognoz Add-In versions match.
If bitness and versions do not match, install applications with matching bitness and versions.
If the PROGNOZ tab has not appeared, go to document options and on the Add-Ins tab select the Prognoz Add-In in the list of inactive add-ins.
In the Manage drop-down list select the COM Add-Ins option and click the Go button.
Then select the checkbox next to the add-in and click the OK button.
For the changes to take effect, restart a Microsoft Office application.

The operating system in English on login to repository displays question marks instead of names in Russian
Problem
On working in the operating system in English after connecting to repository, object names set in Russian are displayed as question marks.
Cause
A repository has been created in a Russian operating system, and the checkbox For Unicode Charset dialog box.
Solution
This problem can be solved only by recreating a repository and selecting the For Unicode Charset checkbox. The databases that contain repository settings must also have the Use Unicode Encoding for Data Representation was not selected for it.

DBMS repository connection throws the error "ERROR: ORA-21561: OID Generation Failed"
Problem
After Prognoz Platform BI server has been installed in a RedHat-based distribution kit, on connecting to Oracle DBMS based repository the error occurs
ERROR: ORA-21561: OID generation failed.
Cause
The error is related with Prognoz Platform, this may be due to the hosts file contents.
Solution
To resolve the error, perform the following operations:
Find computer's IP address ("ip a" command) and computer network name ("hostname" command).
sudo nano /etc/hosts

On creating a repository at PostgreSQL server an error message appears
Problem
After finishing preparation of PostgreSQL server, when repository is created, the repository manager shows the error message.
Cause
Most frequently errors on working with PostgreSQL driver occur when the path to the Bin folder of the PostgreSQL driver is not added to the Path variable in Windows environment variables.
Solution
It is required to set up PostgreSQL server strictly according to help materials:
PostgreSQL server is prepared by the DBMS administrator. The preparation includes the steps described in the Preparing PostgreSQL Server checkbox selected.
After all steps in the item 1 have been successfully executed, go to repository creation.

Error converting MDM dictionary or composite MDM dictionary into table MDM dictionary
Problem
An error occurs on converting MDM dictionary or composite MDM dictionary into table MDM dictionary. Possible error text:
OLE\COM 0x80040E14. Microsoft SQL Server Native Client 10.0 MSSQL-102: Incorrect syntax near '@errno'.
Cause
If metadata schema was earlier transferred Form Microsoft SQL Server 2008 to Microsoft SQL Server 2012, MDM dictionaries are not converted. Transferring of schemas between different DBMS versions is not supported due to difference in SQL syntax.
Solution
Update MDM repository by means of repository manager (RepoMngr.exe). After the successful update repeat dictionary conversion.
Problem
On working with the web application under the user who is not a local administrator or is not in the list of users of the computer with installed BI server, the error occurs:
Catastrophic failure.
Cause
The error occurs if the ForeExec operation is used on executing of any Fore.NET method. It is related with the error of .NET Framework which addresses the registry branch of the system account NetworkService - [HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings], and cannot access it. The BI server application pool is started under this account.
Solution
To solve the problem, grant the user, under whom the work is executed, registry reading permissions.
See also:
Solving Possible Problems on Installing, Starting, and Working in Prognoz Platform 9