Выполнение операций с элементами

При работе с элементами справочника доступны операции:

Выделение элементов

Для выделения одного элемента щёлкните по его наименованию.

Для выделения всех элементов выполните команду «Правка > Выделить все» в главном меню.

Примечание. Выделение всех элементов доступно только в веб-приложении.

Для выборочной отметки зажмите клавишу CTRL, после чего последовательно щёлкните по элементам, которые необходимо выделить.

Для выделения диапазона элементов зажмите клавишу SHIFT, после чего щёлкните первый и последний элемент диапазона. Элементы будут выделены со всеми подчинёнными элементами.

Примечание. Выделение диапазона элементов доступно только в настольном приложении.

Также в настольном приложении возможна установка отметки элементов:

Отметить все

Отметить уровень

Отметить подчиненные

Обновление элементов

Для обновления списка элементов справочника, открытого на просмотр:

Если справочник параметрический, то отобразится диалог «Установка значений параметров». В полях ввода значений параметров будут отражены предыдущие значения.

Примечание. В веб-приложении обновление списка элементов доступно только для справочника НСИ.

При работе с элементами справочника НСИ, открытого на просмотр в веб-приложении или открытого на редактирование в настольном приложении, доступны операции обновления:

Примечание. Автоматическое обновление доступно только в настольном приложении для параметрического справочника НСИ.

Управление отображением скрытых элементов справочника НСИ

Для управления отображением скрытых элементов справочника НСИ, открытого на просмотр в веб-приложении или открытого на редактирование в настольном приложении, используйте флажок «Показать скрытые элементы» в главном меню «Вид».

Перемещение элементов справочника НСИ

Структура элементов справочника НСИ используется для построения множества объектов. При перемещении элемента выполняется автоматическое сохранение изменений.

Для предотвращения ошибочного изменения структуры элементов справочника НСИ установите флажок «Подтверждать перемещения элемента» в главном меню «Вид». После чего при перемещении элемента будет отображаться диалог подтверждения выполняемого действия. По умолчанию флажок снят. Управление состоянием флажка по умолчанию осуществляется с помощью атрибута RdsElementsMoveWarning в файле PP.xml.

Примечание. Настройка предотвращения ошибочного изменения структуры элементов справочника НСИ доступна только в веб-приложении.

Перемещение элемента вверх/вниз

Перемещение элемента между уровнями

При перемещении элементов учитывайте следующие особенности:

Перемещать элементы можно, используя буфер обмена. Для получения подробной информации обратитесь к статье «Работа с элементами справочника НСИ через буфер обмена».

Перенос элементов справочника НСИ между репозиториями

Примечание. Доступно только в настольном приложении.

Элементы справочника НСИ, открытого на редактирование, можно добавлять в обновление для переноса между репозиториями.

Добавление элемента справочника НСИ в обновление

Удаление элемента справочника НСИ из обновления

См. также:

Работа со справочником